Useful or not, from you.
Marlin [BUG] Enabling SD support and/or EEPROM has made SKR 1.4 Turbo unresponsive

<!--

Have you read Marlin's Code of Conduct? By filing an Issue, you are expected to comply with it, including treating everyone with respect: https://github.com/MarlinFirmware/Marlin/blob/bugfix-2.0.x/.github/code_of_conduct.md

Do you want to ask a question? Are you looking for support? Please don't post here. Instead please use the Marlin Firmware forum at http://forums.reprap.org/list.php?415 or the Marlin Facebook Group https://www.facebook.com/groups/1049718498464482/ or the Marlin Discord Server https://discord.gg/n5NJ59y.

Before filing an issue be sure to test the 1.1 and/or 2.0 "bugfix" branches to see whether the issue is already addressed.

-->

Description

After enabling SD support and EEPROM support in Marlin, compiling, and flashing to SKR 1.4 Turbo, display is powered up, but blank. I've checked cables, connectors, verified the display is working on another board. I've disconnected everything from the board except the display and still can't get anything to show up, even with a basic bare bones marlin configuration. Board was working fine before enabling these 2 features, now it won't even show up via USB.

Steps to Reproduce

<!-- If this is a Bug Report, please describe the steps needed to reproduce the issue -->

  1. Compile marlin for SKR 1.4 Turbo using CR-10 stock display.

  2. Flash marlin to SKR 1.4 Turbo

Expected behavior: EEPROM and SD support enabled along with working display

Actual behavior: No display, firmware.bin is still replaced with firmware.cur as expected, but no observable indication that firmware is running on the board.

That's a useful answer
Without any help

the maintainers made a boo-boo and bugfix 2.0.x does not compile, a lot of people have problems

i'm not a coder or maintainer so cant tell when it will work again