Useful or not, from you.
react-native Question: RN 0.60 version pod install glog (0.3.5) error, help me!! T_T

bogon:ios ls$ pod install Analyzing dependencies Fetching podspec for DoubleConversion from ../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec Fetching podspec for Folly from ../node_modules/react-native/third-party-podspecs/Folly.podspec Fetching podspec for React from ../node_modules/react-native/ Fetching podspec for React-Core from ../node_modules/react-native/React Fetching podspec for React-DevSupport from ../node_modules/react-native/React Fetching podspec for React-RCTActionSheet from ../node_modules/react-native/Libraries/ActionSheetIOS Fetching podspec for React-RCTAnimation from ../node_modules/react-native/Libraries/NativeAnimation Fetching podspec for React-RCTBlob from ../node_modules/react-native/Libraries/Blob Fetching podspec for React-RCTImage from ../node_modules/react-native/Libraries/Image Fetching podspec for React-RCTLinking from ../node_modules/react-native/Libraries/LinkingIOS Fetching podspec for React-RCTNetwork from ../node_modules/react-native/Libraries/Network Fetching podspec for React-RCTSettings from ../node_modules/react-native/Libraries/Settings Fetching podspec for React-RCTText from ../node_modules/react-native/Libraries/Text Fetching podspec for React-RCTVibration from ../node_modules/react-native/Libraries/Vibration Fetching podspec for React-RCTWebSocket from ../node_modules/react-native/Libraries/WebSocket Fetching podspec for React-cxxreact from ../node_modules/react-native/ReactCommon/cxxreact Fetching podspec for React-fishhook from ../node_modules/react-native/Libraries/fishhook Fetching podspec for React-jsi from ../node_modules/react-native/ReactCommon/jsi Fetching podspec for React-jsiexecutor from ../node_modules/react-native/ReactCommon/jsiexecutor Fetching podspec for React-jsinspector from ../node_modules/react-native/ReactCommon/jsinspector Fetching podspec for glog from ../node_modules/react-native/third-party-podspecs/glog.podspec Fetching podspec for yoga from ../node_modules/react-native/ReactCommon/yoga Downloading dependencies Installing DoubleConversion (1.1.6) Installing Folly (2018.10.22.00) Installing React (0.60.0) Installing React-Core (0.60.0) Installing React-DevSupport (0.60.0) Installing React-RCTActionSheet (0.60.0) Installing React-RCTAnimation (0.60.0) Installing React-RCTBlob (0.60.0) Installing React-RCTImage (0.60.0) Installing React-RCTLinking (0.60.0) Installing React-RCTNetwork (0.60.0) Installing React-RCTSettings (0.60.0) Installing React-RCTText (0.60.0) Installing React-RCTVibration (0.60.0) Installing React-RCTWebSocket (0.60.0) Installing React-cxxreact (0.60.0) Installing React-fishhook (0.60.0) Installing React-jsi (0.60.0) Installing React-jsiexecutor (0.60.0) Installing React-jsinspector (0.60.0) Installing boost-for-react-native (1.63.0) Installing glog (0.3.5) [!] /bin/bash -c set -e #!/bin/bash

Copyright (c) Facebook, Inc. and its affiliates.

This source code is licensed under the MIT license found in the

LICENSE file in the root directory of this source tree.

set -e

PLATFORM_NAME="${PLATFORM_NAME:-iphoneos}" CURRENT_ARCH="${CURRENT_ARCH}"

if [ -z "$CURRENT_ARCH" ] || [ "$CURRENT_ARCH" == "undefined_arch" ]; then # Xcode 10 beta sets CURRENT_ARCH to "undefined_arch", this leads to incorrect linker arg. # it's better to rely on platform name as fallback because architecture differs between simulator and device

if [[ "$PLATFORM_NAME" == *"simulator"* ]]; then
    CURRENT_ARCH="x86_64"
else
    CURRENT_ARCH="armv7"
fi

fi

export CC="$(xcrun -find -sdk $PLATFORM_NAME cc) -arch $CURRENT_ARCH -isysroot $(xcrun -sdk $PLATFORM_NAME --show-sdk-path)" export CXX="$CC"

Remove automake symlink if it exists

if [ -h "test-driver" ]; then rm test-driver fi

./configure --host arm-apple-darwin

Fix build for tvOS

cat << EOF >> src/config.h

/* Add in so we have Apple Target Conditionals */ #ifdef APPLE #include <TargetConditionals.h> #include <Availability.h> #endif

/* Special configuration for AppleTVOS */ #if TARGET_OS_TV #undef HAVE_SYSCALL_H #undef HAVE_SYS_SYSCALL_H #undef OS_MACOSX #endif

/* Special configuration for ucontext */ #undef HAVE_UCONTEXT_H #undef PC_FROM_UCONTEXT #if defined(x86_64) #define PC_FROM_UCONTEXT uc_mcontext->__ss.__rip #elif defined(i386) #define PC_FROM_UCONTEXT uc_mcontext->__ss.__eip #endif EOF

Prepare exported header include

EXPORTED_INCLUDE_DIR="exported/glog" mkdir -p exported/glog cp -f src/glog/log_severity.h "$EXPORTED_INCLUDE_DIR/" cp -f src/glog/logging.h "$EXPORTED_INCLUDE_DIR/" cp -f src/glog/raw_logging.h "$EXPORTED_INCLUDE_DIR/" cp -f src/glog/stl_logging.h "$EXPORTED_INCLUDE_DIR/" cp -f src/glog/vlog_is_on.h "$EXPORTED_INCLUDE_DIR/"

checking for a BSD-compatible install... /usr/local/bin/ginstall -c checking whether build environment is sane... yes checking for arm-apple-darwin-strip... no checking for strip... strip checking for a thread-safe mkdir -p... /usr/local/bin/gmkdir -p checking for gawk... no checking for mawk... no checking for nawk... no checking for awk... awk checking whether make sets $(MAKE)... yes checking whether make supports nested variables... yes checking for arm-apple-darwin-gcc... /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/cc -arch armv7 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk checking whether the C compiler works... no /Users/ls/Library/Caches/CocoaPods/Pods/External/glog/2263bd123499e5b93b5efe24871be317-1f3da/missing: Unknown --is-lightweight' option Try/Users/ls/Library/Caches/CocoaPods/Pods/External/glog/2263bd123499e5b93b5efe24871be317-1f3da/missing --help' for more information configure: WARNING: 'missing' script is too old or missing configure: error: in /Users/ls/Library/Caches/CocoaPods/Pods/External/glog/2263bd123499e5b93b5efe24871be317-1f3da': configure: error: C compiler cannot create executables Seeconfig.log' for more details I used sudo xcode-select --switch /Applications/Xcode.app but it didn't solve my problem. image

That's a useful answer
Without any help

sudo xcode-select --switch /Applications/Xcode.app