Useful or not, from you.
flutter flutter doctor is not working, Error : Checking Dart SDK version... 'PowerShell.exe' is not recognized as an internal or external command, operable program or batch file. Error: Unable to update Dart SDK. Retrying...

I followed the procedure mentioned in the documentation

  1. I have installed the git for windows
  2. Then used this command in cmd : $ git clone -b beta https://github.com/flutter/flutter.git
  3. Then i set the environment path in user variables of flutter.
  4. Then using flutter doctor i got this error :

C:\Windows\System32>flutter doctor Checking Dart SDK version... 'PowerShell.exe' is not recognized as an internal or external command, operable program or batch file. Error: Unable to update Dart SDK. Retrying...

That's a useful answer
Without any help

yes it works.