Useful or not, from you.
flutter Flutter firestore platform exception

When trying to access cloud firestore using emulator/other phones I get the following error:

W/DynamiteModule( 4277): Local module descriptor class for providerinstaller not found.
I/DynamiteModule( 4277): Considering local module com.google.android.gms.flags:3 and remote module com.google.android.gms.flags:0
I/DynamiteModule( 4277): Selected local version of com.google.android.gms.flags
I/DynamiteModule( 4277): Considering local module providerinstaller:0 and remote module providerinstaller:0
W/ProviderInstaller( 4277): Failed to load providerinstaller module: No acceptable module found. Local version is 0 and remote version is 0.
W/System  ( 4277): ClassLoader referenced unknown path: /system/priv-app/PrebuiltGmsCore/lib/x86_64
W/System  ( 4277): ClassLoader referenced unknown path: /system/priv-app/PrebuiltGmsCore/lib/x86_64
W/System  ( 4277): ClassLoader referenced unknown path: /system/priv-app/PrebuiltGmsCore/lib/x86_64
W/System  ( 4277): ClassLoader referenced unknown path: /system/priv-app/PrebuiltGmsCore/lib/x86_64
W/System  ( 4277): ClassLoader referenced unknown path: /system/priv-app/PrebuiltGmsCore/lib/x86_64
W/linker  ( 4277): /data/data/com.google.android.gms/app_extracted_libs/x86_64/libconscrypt_gmscore_jni.so: unused DT entry: type 0xf arg 0x12a
V/NativeCrypto( 4277): Registering com/google/android/gms/org/conscrypt/NativeCrypto's 276 native methods...
I/art     ( 4277): Rejecting re-init on previously-failed class java.lang.Class<com.google.android.gms.org.conscrypt.DelegatingExtendedSSLSession>
I/art     ( 4277): Rejecting re-init on previously-failed class java.lang.Class<com.google.android.gms.org.conscrypt.DelegatingExtendedSSLSession>
I/art     ( 4277): Rejecting re-init on previously-failed class java.lang.Class<com.google.android.gms.org.conscrypt.DelegatingExtendedSSLSession>
I/ProviderInstaller( 4277): Installed default security provider GmsCore_OpenSSL
I/flutter ( 4277): Inside
W/ManagedChannelImpl( 4277): [{0}] Failed to resolve name. status={1}
W/ManagedChannelImpl( 4277): [{0}] Failed to resolve name. status={1}
W/ManagedChannelImpl( 4277): [{0}] Failed to resolve name. status={1}
W/ManagedChannelImpl( 4277): [{0}] Failed to resolve name. status={1}
W/ManagedChannelImpl( 4277): [{0}] Failed to resolve name. status={1}

Although when I use my phone via USB works fine.

flutter

Here's my flutter doctor -v

[√] Flutter (Channel beta, v1.1.8, on Microsoft Windows [Version 10.0.17134.523], locale en-IN)
    • Flutter version 1.1.8 at C:\flutter\flutter
    • Framework revision 985ccb6d14 (5 weeks ago), 2019-01-08 13:45:55 -0800
    • Engine revision 7112b72cc2
    • Dart version 2.1.1 (build 2.1.1-dev.0.1 ec86471ccc)

[√] Android toolchain - develop for Android devices (Android SDK version 28.0.3)
    • Android SDK at C:\Users\adity\AppData\Local\Android\sdk
    • Android NDK location not configured (optional; useful for native profiling support)
    • Platform android-28, build-tools 28.0.3
    • Java binary at: C:\Program Files\Android\Android Studio\jre\bin\java
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1136-b06)
    • All Android licenses accepted.

[√] Android Studio (version 3.2)
    • Android Studio at C:\Program Files\Android\Android Studio
    • Flutter plugin version 31.1.1
    • Dart plugin version 181.5656
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1136-b06)

[√] VS Code, 64-bit edition (version 1.30.1)
    • VS Code at C:\Program Files\Microsoft VS Code
    • Flutter extension version 2.22.3

[√] Connected device (1 available)
    • Android SDK built for x86 64 • emulator-5554 • android-x64 • Android 6.0 (API 23) (emulator)

• No issues found!

@zoechi Please help

That's a useful answer
Without any help

I still got this error when run on my Samsung Note 9 or on simulator W/DynamiteModule(24562): Local module descriptor class for providerinstaller not found. I/DynamiteModule(24562): Considering local module providerinstaller:0 and remote module providerinstaller:0 W/ProviderInstaller(24562): Failed to load providerinstaller module: No acceptable module found. Local version is 0 and remote version is 0.