Useful or not, from you.
flutter Getting "Error retrieving thread information: (ipc/send) invalid destination port" in the logs on Apple Silicon M1

When compiling the counter app I receive the following error every ~200 ms:

[ +206 ms] [VERBOSE-2:profiler_metrics_ios.mm(184)] Error retrieving thread information: (ipc/send) invalid destination port

flutter doctor and flutter run -v doesn't give any visible errors.

Screenshot 2020-11-28 at 10 48 16

That's a useful answer
Without any help

Got the new MacBook Air with M1 chip today (Dec 9, 2020). Same Issue. I get about 5 messages every second.

Since everything seems to be working fine... Is there a way to disable this?

flutter: ===== STARTING APP =====
flutter: 2020-12-09 19:19:33.388298: MainApp INFO: ===== STARTING APP =====
[VERBOSE-2:profiler_metrics_ios.mm(184)] Error retrieving thread information: (ipc/send) invalid destination port
[VERBOSE-2:profiler_metrics_ios.mm(184)] Error retrieving thread information: (ipc/send) invalid destination port
[VERBOSE-2:profiler_metrics_ios.mm(184)] Error retrieving thread information: (ipc/send) invalid destination port
[VERBOSE-2:profiler_metrics_ios.mm(184)] Error retrieving thread information: (ipc/send) invalid destination port
flutter: 2020-12-09 19:19:34.147637: MainApp INFO: AppNavigationObserver didPush from null to CupertinoPageRoute<dynamic>(RouteSettings("/", null), animation: AnimationController#98bbb(⏭ 1.000; paused; for CupertinoPageRoute<dynamic>(/)))

Brand new fresh setup....

flutter doctor -v
[✓] Flutter (Channel stable, 1.22.4, on macOS 11.0.1 20B29 darwin-arm, locale en-US)
    • Flutter version 1.22.4 at /Users/agautam/tools/flutter
    • Framework revision 1aafb3a8b9 (4 weeks ago), 2020-11-13 09:59:28 -0800
    • Engine revision 2c956a31c0
    • Dart version 2.10.4

 
[✓] Android toolchain - develop for Android devices (Android SDK version 30.0.3)
    • Android SDK at /Users/agautam/Library/Android/sdk
    • Platform android-30, build-tools 30.0.3
    • Java binary at: /Applications/Android Studio.app/Contents/jre/jdk/Contents/Home/bin/java
    • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b3-6915495)
    • All Android licenses accepted.

[✓] Xcode - develop for iOS and macOS (Xcode 12.2)
    • Xcode at /Applications/Xcode.app/Contents/Developer
    • Xcode 12.2, Build version 12B45b
    • CocoaPods version 1.10.0

[!] Android Studio (version 4.1)
    • Android Studio at /Applications/Android Studio.app/Contents
    ✗ Flutter plugin not installed; this adds Flutter specific functionality.
    ✗ Dart plugin not installed; this adds Dart specific functionality.
    • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b3-6915495)

[✓] VS Code (version 1.51.1)
    • VS Code at /Applications/Visual Studio Code.app/Contents
    • Flutter extension version 3.17.0

[✓] Connected device (1 available)
    • iPhone 12 Pro Max (mobile) • 791FFAFB-CD39-4FA5-9A1B-DE42A8406147 • ios • com.apple.CoreSimulator.SimRuntime.iOS-14-2 (simulator)