Useful or not, from you.
flutter Local module descriptor class for providerinstaller not found in flutter

I have this form where user registers his/her details and saves it in google firestore, which actually works because the details are stored in firestore and i can log in with those details if i want but i keep getting this error whenever i submit the details.

I/zygote (20683): Do partial code cache collection, code=56KB, data=61KB I/zygote (20683): After code cache collection, code=55KB, data=60KB I/zygote (20683): Increasing code cache capacity to 256KB D/GraphicBuffer(20683): register, handle(0x8d0f9bc0) (w:720 h:1344 s:720 f:0x1 u:f02) I/zygote (20683): Do full code cache collection, code=125KB, data=109KB I/zygote (20683): After code cache collection, code=99KB, data=69KB W/System (20683): Ignoring header X-Firebase-Locale because its value was null. I/System.out(20683): isEmailSend:POST I/System.out(20683): port:443 I/System.out(20683): Check isMmsSendPdu I/System.out(20683): [OkHttp] sendRequest<< W/System (20683): Ignoring header X-Firebase-Locale because its value was null. I/System.out(20683): isEmailSend:POST I/System.out(20683): Check isMmsSendPdu I/System.out(20683): [OkHttp] sendRequest<< D/FirebaseAuth(20683): Notifying id token listeners about user ( BFN7FUKuGvMpIBaYSIpxnbkTjzB3 ). D/FirebaseAuth(20683): Notifying auth state listeners about user ( BFN7FUKuGvMpIBaYSIpxnbkTjzB3 ). W/DynamiteModule(20683): Local module descriptor class for providerinstaller not found. I/DynamiteModule(20683): Considering local module providerinstaller:0 and remote module providerinstaller:0 W/ProviderInstaller(20683): Failed to load providerinstaller module: No acceptable module found. Local version is 0 and remote version is 0. I/zygote (20683): The ClassLoaderContext is a special shared library. I/zygote (20683): The ClassLoaderContext is a special shared library. D/SharedPreferencesImpl(20683): Time required to fsync /data/user/0/com.brightapps.book_club/shared_prefs/com.google.firebase.auth.api.Store.W0RFRkFVTFRd+MToyMTI3NDMzNDk2MjE6YW5kcm9pZDplMjc0M2UyNTMwMDNlZGM2YTVkZjNj.xml: [<1: 0, <2: 0, <4: 0, <8: 0, <16: 0, <32: 0, <64: 0, <128: 0, <256: 0, <512: 0, <1024: 0, <2048: 0, <4096: 1, <8192: 0, <16384: 0, >=16384: 0] V/NativeCrypto(20683): Registering com/google/android/gms/org/conscrypt/NativeCrypto's 288 native methods... I/ProviderInstaller(20683): Installed default security provider GmsCore_OpenSSL I/System.out(20683): port:443 I/zygote (20683): Do partial code cache collection, code=125KB, data=97KB I/zygote (20683): After code cache collection, code=125KB, data=97KB I/zygote (20683): Increasing code cache capacity to 512KB `

I have used both emulator and my mobile device (which is what am using for this error above) to test it and its still the same flutter doctor -v

P:\flutter\book_club>flutter doctor -v [√] Flutter (Channel stable, 1.22.1, on Microsoft Windows [Version 6.3.9600], locale en-US) • Flutter version 1.22.1 at C:\src\flutter • Framework revision f30b7f4db9 (2 months ago), 2020-10-08 10:06:30 -0700 • Engine revision 75bef9f6c8 • Dart version 2.10.1 [√] Android toolchain - develop for Android devices (Android SDK version 30.0.3) • Android SDK at C:\Users\brightisaac\AppData\Local\Android\Sdk • Platform android-30, build-tools 30.0.3 • Java binary at: C:\Program Files\Android\Android Studio\jre\bin\java • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b01) • All Android licenses accepted. [√] Android Studio (version 3.5) • Android Studio at C:\Program Files\Android\Android Studio • Flutter plugin version 44.0.1 • Dart plugin version 191.8593 • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b01) [√] VS Code (version 1.44.2) • VS Code at C:\Users\brightisaac\AppData\Local\Programs\Microsoft VS Code • Flutter extension version 3.12.2 [√] Connected device (2 available) • Infinix X606C (mobile) • ************* • android-arm • Android 8.1.0 (API 27) • Android SDK built for x86 (mobile) • emulator-5554 • android-x86 • Android 10 (API 29) (emulator) • No issues found!

flutter run --verbose

[ +249 ms] executing: [C:\src\flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H [ +142 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H [ ] f30b7f4db93ee747cd727df747941a28ead25ff5 [ +1 ms] executing: [C:\src\flutter/] git tag --points-at HEAD [ +79 ms] Exit code 0 from: git tag --points-at HEAD [ ] 1.22.0-12.4.pre 1.22.1 [ +17 ms] executing: [C:\src\flutter/] git rev-parse --abbrev-ref --symbolic @{u} [ +61 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u} [ ] origin/stable [ ] executing: [C:\src\flutter/] git ls-remote --get-url origin [ +52 ms] Exit code 0 from: git ls-remote --get-url origin [ ] https://github.com/flutter/flutter.git [ +131 ms] executing: [C:\src\flutter/] git rev-parse --abbrev-ref HEAD [ +57 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD [ ] stable [ +103 ms] Artifact Instance of 'AndroidMavenArtifacts' is not required, skipping update. [ ] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update. [ ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update. [ ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update. [ ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update. [ +9 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update. [ ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update. [ ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update. [ ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update. [ ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update. [ +3 ms] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update. [ +1 ms] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update. [ +78 ms] executing: C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe devices -l [ +141 ms] List of devices attached 03263258BC003765 device product:H8023C model:Infinix_X606C device:Infinix-X606C transport_id:5 [ +14 ms] C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe -s 03263258BC003765 shell getprop [ +152 ms] Artifact Instance of 'AndroidMavenArtifacts' is not required, skipping update. [ +8 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update. [ +1 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update. [ ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update. [ +32 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update. [ +4 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update. [ ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update. [ ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update. [ ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update. [ ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update. [ ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update. [ +280 ms] Found plugin cloud_firestore at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\cloud_firestore-0.14.4
[ +19 ms] Found plugin cloud_firestore_web at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\cloud_firestore_web-0.2.1+2
[ +20 ms] Found plugin firebase_auth at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\firebase_auth-0.18.3+1
[ +10 ms] Found plugin firebase_auth_web at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\firebase_auth_web-0.3.2+1
[ +6 ms] Found plugin firebase_core at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\firebase_core-0.5.3
[ +10 ms] Found plugin firebase_core_web at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\firebase_core_web-0.2.1+1
[ +10 ms] Found plugin google_sign_in at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\google_sign_in-4.5.6
[ +7 ms] Found plugin google_sign_in_web at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\google_sign_in_web-0.9.2
[ +5 ms] Found plugin hexcolor at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\hexcolor-1.0.6
[ +360 ms] Found plugin cloud_firestore at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\cloud_firestore-0.14.4
[ +7 ms] Found plugin cloud_firestore_web at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\cloud_firestore_web-0.2.1+2
[ +9 ms] Found plugin firebase_auth at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\firebase_auth-0.18.3+1
[ +7 ms] Found plugin firebase_auth_web at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\firebase_auth_web-0.3.2+1
[ +5 ms] Found plugin firebase_core at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\firebase_core-0.5.3
[ +7 ms] Found plugin firebase_core_web at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\firebase_core_web-0.2.1+1
[ +3 ms] Found plugin google_sign_in at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\google_sign_in-4.5.6
[ +6 ms] Found plugin google_sign_in_web at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\google_sign_in_web-0.9.2
[ +4 ms] Found plugin hexcolor at C:\Users\brightisaac\AppData\Local\Pub\Cache\hosted\pub.dartlang.org\hexcolor-1.0.6
[ +85 ms] Generating P:\flutter\book_club\android\app\src\main\java\io\flutter\plugins\GeneratedPluginRegistrant.java [ +67 ms] ro.hardware = mt6580 [ ] ro.build.characteristics = default [ +118 ms] Starting incremental build... [ +6 ms] Initializing file store [ +25 ms] Skipping target: gen_localizations [ +10 ms] complete [ +12 ms] Launching lib\main.dart on Infinix X606C in debug mode... [ +16 ms] C:\src\flutter\bin\cache\dart-sdk\bin\dart.exe --disable-dart-dev C:\src\flutter\bin\cache\artifacts\engine\windows-x64\frontend_server.dart.snapshot --sdk-root C:\src\flutter\bin\cache\artifacts\engine\common\flutter_patched_sdk/ --incremental --target=flutter --debugger-module-names --experimental-emit-debug-metadata -Ddart.developer.causal_async_stacks=true --output-dill C:\Users\BRIGHT~1\AppData\Local\Temp\flutter_tools.508daff\flutter_tool.6887f817\app.dill --packages .packages -Ddart.vm.profile=false -Ddart.vm.product=false --bytecode-options=source-positions,local-var-info,debugger-stops,instance-field-initializers,keep-unreachable-code,avoid-closure-call-instructions --enable-asserts --track-widget-creation --filesystem-scheme org-dartlang-root --initialize-from-dill build\cache.dill.track.dill [ +33 ms] executing: C:\Users\brightisaac\AppData\Local\Android\Sdk\build-tools\30.0.3\aapt dump xmltree P:\flutter\book_club\build\app\outputs\flutter-apk\app.apk AndroidManifest.xml [ +222 ms] Exit code 0 from: C:\Users\brightisaac\AppData\Local\Android\Sdk\build-tools\30.0.3\aapt dump xmltree P:\flutter\book_club\build\app\outputs\flutter-apk\app.apk AndroidManifest.xml [ +1 ms] N: android=http://schemas.android.com/apk/res/android E: manifest (line=2) A: android:versionCode(0x0101021b)=(type 0x10)0x1 A: android:versionName(0x0101021c)="1.0.0" (Raw: "1.0.0") A: android:compileSdkVersion(0x01010572)=(type 0x10)0x1d A: android:compileSdkVersionCodename(0x01010573)="10" (Raw: "10") A: package="com.brightapps.book_club" (Raw: "com.brightapps.book_club") A: platformBuildVersionCode=(type 0x10)0x1d A: platformBuildVersionName=(type 0x10)0xa E: uses-sdk (line=7) A: android:minSdkVersion(0x0101020c)=(type 0x10)0x15 A: android:targetSdkVersion(0x01010270)=(type 0x10)0x1d E: uses-permission (line=14) A: android:name(0x01010003)="android.permission.INTERNET" (Raw: "android.permission.INTERNET") E: uses-permission (line=15) A: android:name(0x01010003)="android.permission.ACCESS_NETWORK_STATE" (Raw: "android.permission.ACCESS_NETWORK_STATE") E: uses-permission (line=16) A: android:name(0x01010003)="android.permission.WAKE_LOCK" (Raw: "android.permission.WAKE_LOCK") E: uses-permission (line=17) A: android:name(0x01010003)="com.google.android.finsky.permission.BIND_GET_INSTALL_REFERRER_SERVICE" (Raw: "com.google.android.finsky.permission.BIND_GET_INSTALL_REFERRER_SERVICE") E: application (line=25) A: android:label(0x01010001)="book_club" (Raw: "book_club") A: android:icon(0x01010002)=@0x7f080000 A: android:name(0x01010003)="io.flutter.app.FlutterApplication" (Raw: "io.flutter.app.FlutterApplication") A: android:debuggable(0x0101000f)=(type 0x12)0xffffffff A: android:appComponentFactory(0x0101057a)="androidx.core.app.CoreComponentFactory" (Raw: "androidx.core.app.CoreComponentFactory") E: activity (line=31) A: android:theme(0x01010000)=@0x7f0a0000 A: android:name(0x01010003)="com.brightapps.book_club.MainActivity" (Raw: "com.brightapps.book_club.MainActivity") A: android:launchMode(0x0101001d)=(type 0x10)0x1 A: android:configChanges(0x0101001f)=(type 0x11)0x40003fb4 A: android:windowSoftInputMode(0x0101022b)=(type 0x11)0x10 A: android:hardwareAccelerated(0x010102d3)=(type 0x12)0xffffffff E: meta-data (line=45) A: android:name(0x01010003)="io.flutter.embedding.android.NormalTheme" (Raw: "io.flutter.embedding.android.NormalTheme") A: android:resource(0x01010025)=@0x7f0a0001 E: meta-data (line=55) A: android:name(0x01010003)="io.flutter.embedding.android.SplashScreenDrawable" (Raw: "io.flutter.embedding.android.SplashScreenDrawable") A: android:resource(0x01010025)=@0x7f040015 E: intent-filter (line=59) E: action (line=60) A: android:name(0x01010003)="android.intent.action.MAIN" (Raw: "android.intent.action.MAIN") E: category (line=62) A: android:name(0x01010003)="android.intent.category.LAUNCHER" (Raw: "android.intent.category.LAUNCHER") E: meta-data (line=69) A: android:name(0x01010003)="flutterEmbedding" (Raw: "flutterEmbedding") A: android:value(0x01010024)=(type 0x10)0x2 E: service (line=73) A: android:name(0x01010003)="com.google.firebase.components.ComponentDiscoveryService" (Raw: "com.google.firebase.components.ComponentDiscoveryService") A: android:exported(0x01010010)=(type 0x12)0x0 A: android:directBootAware(0x01010505)=(type 0x12)0xffffffff E: meta-data (line=77) A: android:name(0x01010003)="com.google.firebase.components:io.flutter.plugins.firebase.auth.FlutterFirebaseAuthRegistrar" (Raw: "com.google.firebase.components:io.flutter.plugins.firebase.auth.FlutterFirebaseAuthRegistrar") A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar") E: meta-data (line=80) A: android:name(0x01010003)="com.google.firebase.components:io.flutter.plugins.firebase.firestore.FlutterFirebaseFirestoreRegistra r" (Raw: "com.google.firebase.components:io.flutter.plugins.firebase.firestore.FlutterFirebaseFirestoreRegistrar") A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar") E: meta-data (line=83) A: android:name(0x01010003)="com.google.firebase.components:io.flutter.plugins.firebase.core.FlutterFirebaseCoreRegistrar" (Raw: "com.google.firebase.components:io.flutter.plugins.firebase.core.FlutterFirebaseCoreRegistrar") A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar") E: meta-data (line=86) A: android:name(0x01010003)="com.google.firebase.components:com.google.firebase.auth.FirebaseAuthRegistrar" (Raw: "com.google.firebase.components:com.google.firebase.auth.FirebaseAuthRegistrar") A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar") E: meta-data (line=89) A: android:name(0x01010003)="com.google.firebase.components:com.google.firebase.firestore.FirestoreRegistrar" (Raw: "com.google.firebase.components:com.google.firebase.firestore.FirestoreRegistrar") A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar") E: meta-data (line=92) A: android:name(0x01010003)="com.google.firebase.components:com.google.firebase.analytics.connector.internal.AnalyticsConnectorReg istrar" (Raw: "com.google.firebase.components:com.google.firebase.analytics.connector.internal.AnalyticsConnectorRegistrar") A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar") E: meta-data (line=95) A: android:name(0x01010003)="com.google.firebase.components:com.google.firebase.installations.FirebaseInstallationsRegistrar" (Raw: "com.google.firebase.components:com.google.firebase.installations.FirebaseInstallationsRegistrar") A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar") E: activity (line=100) A: android:theme(0x01010000)=@0x01030010 A: android:name(0x01010003)="com.google.firebase.auth.internal.GenericIdpActivity" (Raw: "com.google.firebase.auth.internal.GenericIdpActivity") A: android:exported(0x01010010)=(type 0x12)0xffffffff A: android:excludeFromRecents(0x01010017)=(type 0x12)0xffffffff A: android:launchMode(0x0101001d)=(type 0x10)0x2 E: intent-filter (line=106) E: action (line=107) A: android:name(0x01010003)="android.intent.action.VIEW" (Raw: "android.intent.action.VIEW") E: category (line=109) A: android:name(0x01010003)="android.intent.category.DEFAULT" (Raw: "android.intent.category.DEFAULT") E: category (line=110) A: android:name(0x01010003)="android.intent.category.BROWSABLE" (Raw: "android.intent.category.BROWSABLE") E: data (line=112) A: android:scheme(0x01010027)="genericidp" (Raw: "genericidp") A: android:host(0x01010028)="firebase.auth" (Raw: "firebase.auth") A: android:path(0x0101002a)="/" (Raw: "/") E: activity (line=118) A: android:theme(0x01010000)=@0x01030010 A: android:name(0x01010003)="com.google.firebase.auth.internal.RecaptchaActivity" (Raw: "com.google.firebase.auth.internal.RecaptchaActivity") A: android:exported(0x01010010)=(type 0x12)0xffffffff A: android:excludeFromRecents(0x01010017)=(type 0x12)0xffffffff A: android:launchMode(0x0101001d)=(type 0x10)0x2 E: intent-filter (line=124) E: action (line=125) A: android:name(0x01010003)="android.intent.action.VIEW" (Raw: "android.intent.action.VIEW") E: category (line=127) A: android:name(0x01010003)="android.intent.category.DEFAULT" (Raw: "android.intent.category.DEFAULT") E: category (line=128) A: android:name(0x01010003)="android.intent.category.BROWSABLE" (Raw: "android.intent.category.BROWSABLE") E: data (line=130) A: android:scheme(0x01010027)="recaptcha" (Raw: "recaptcha") A: android:host(0x01010028)="firebase.auth" (Raw: "firebase.auth") A: android:path(0x0101002a)="/" (Raw: "/") E: service (line=137) A: android:name(0x01010003)="com.google.firebase.auth.api.fallback.service.FirebaseAuthFallbackService" (Raw: "com.google.firebase.auth.api.fallback.service.FirebaseAuthFallbackService") A: android:enabled(0x0101000e)=(type 0x12)0xffffffff A: android:exported(0x01010010)=(type 0x12)0x0 E: intent-filter (line=141) E: action (line=142) A: android:name(0x01010003)="com.google.firebase.auth.api.gms.service.START" (Raw: "com.google.firebase.auth.api.gms.service.START") E: category (line=144) A: android:name(0x01010003)="android.intent.category.DEFAULT" (Raw: "android.intent.category.DEFAULT") E: activity (line=148) A: android:theme(0x01010000)=@0x01030010 A: android:name(0x01010003)="com.google.android.gms.auth.api.signin.internal.SignInHubActivity" (Raw: "com.google.android.gms.auth.api.signin.internal.SignInHubActivity") A: android:exported(0x01010010)=(type 0x12)0x0 A: android:excludeFromRecents(0x01010017)=(type 0x12)0xffffffff E: service (line=157) A: android:name(0x01010003)="com.google.android.gms.auth.api.signin.RevocationBoundService" (Raw: "com.google.android.gms.auth.api.signin.RevocationBoundService") A: android:permission(0x01010006)="com.google.android.gms.auth.api.signin.permission.REVOCATION_NOTIFICATION" (Raw: "com.google.android.gms.auth.api.signin.permission.REVOCATION_NOTIFICATION") A: android:exported(0x01010010)=(type 0x12)0xffffffff E: activity (line=162) A: android:theme(0x01010000)=@0x01030010 A: android:name(0x01010003)="com.google.android.gms.common.api.GoogleApiActivity" (Raw: "com.google.android.gms.common.api.GoogleApiActivity") A: android:exported(0x01010010)=(type 0x12)0x0 E: receiver (line=167) A: android:name(0x01010003)="com.google.android.gms.measurement.AppMeasurementReceiver" (Raw: "com.google.android.gms.measurement.AppMeasurementReceiver") A: android:enabled(0x0101000e)=(type 0x12)0xffffffff A: android:exported(0x01010010)=(type 0x12)0x0 E: service (line=173) A: android:name(0x01010003)="com.google.android.gms.measurement.AppMeasurementService" (Raw: "com.google.android.gms.measurement.AppMeasurementService") A: android:enabled(0x0101000e)=(type 0x12)0xffffffff A: android:exported(0x01010010)=(type 0x12)0x0 E: service (line=177) A: android:name(0x01010003)="com.google.android.gms.measurement.AppMeasurementJobService" (Raw: "com.google.android.gms.measurement.AppMeasurementJobService") A: android:permission(0x01010006)="android.permission.BIND_JOB_SERVICE" (Raw: "android.permission.BIND_JOB_SERVICE") A: android:enabled(0x0101000e)=(type 0x12)0xffffffff A: android:exported(0x01010010)=(type 0x12)0x0 E: provider (line=183) A: android:name(0x01010003)="com.google.firebase.provider.FirebaseInitProvider" (Raw: "com.google.firebase.provider.FirebaseInitProvider") A: android:exported(0x01010010)=(type 0x12)0x0 A: android:authorities(0x01010018)="com.brightapps.book_club.firebaseinitprovider" (Raw: "com.brightapps.book_club.firebaseinitprovider") A: android:initOrder(0x0101001a)=(type 0x10)0x64 A: android:directBootAware(0x01010505)=(type 0x12)0xffffffff E: meta-data (line=190) A: android:name(0x01010003)="com.google.android.gms.version" (Raw: "com.google.android.gms.version") A: android:value(0x01010024)=@0x7f060000 [ +41 ms] executing: C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe -s 03263258BC003765 shell -x logcat -v time -t 1 [ +120 ms] Exit code 0 from: C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe -s 03263258BC003765 shell -x logcat -v time -t 1 [ ] --------- beginning of main 12-19 23:06:56.497 I/DisplayDevice( 283): [Built-in Screen (type:0)] fps:27.843578,dur:1472.51,max:661.64,min:8.90 [ +2 ms] executing: C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe -s 03263258BC003765 shell -x logcat -v time -t 1 [ +96 ms] Exit code 0 from: C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe -s 03263258BC003765 shell -x logcat -v time -t 1 [ +1 ms] --------- beginning of main 12-19 23:06:56.497 I/DisplayDevice( 283): [Built-in Screen (type:0)] fps:27.843578,dur:1472.51,max:661.64,min:8.90 [ +10 ms] <- compile package:book_club/main.dart [ +20 ms] executing: C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe version [ +43 ms] Android Debug Bridge version 1.0.41 Version 30.0.5-6877874 Installed as C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe [ +5 ms] executing: C:\Users\brightisaac\AppData\Local\Android\Sdk\platform-tools\adb.exe start-server [ +53 ms] Building APK [ +44 ms] Running Gradle task 'assembleDebug'... [ +4 ms] gradle.properties already sets android.enableR8 [ +8 ms] Using gradle from P:\flutter\book_club\android\gradlew.bat. [ +2 ms] P:\flutter\book_club\android\gradlew.bat mode: 33279 rwxrwxrwx. [ +20 ms] executing: C:\Program Files\Android\Android Studio\jre\bin\java -version [+3462 ms] Exit code 0 from: C:\Program Files\Android\Android Studio\jre\bin\java -version [ ] openjdk version "1.8.0_242-release" OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b01) OpenJDK 64-Bit Server VM (build 25.242-b01, mixed mode) [ +7 ms] executing: [P:\flutter\book_club\android/] P:\flutter\book_club\android\gradlew.bat -Pverbose=true -Ptarget-platform=android-arm -Ptarget=P:\flutter\book_club\lib\main.dart -Ptrack-widget-creation=true -Pfilesystem-scheme=org-dartlang-root assembleDebug [+11664 ms] > Task :app:compileFlutterBuildDebug [ +1 ms] [ +272 ms] executing: [C:\src\flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H [ +1 ms] [ +145 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H [ +3 ms] [ +1 ms] f30b7f4db93ee747cd727df747941a28ead25ff5 [ +1 ms] [ +2 ms] executing: [C:\src\flutter/] git tag --points-at HEAD [ +2 ms] [ +101 ms] Exit code 0 from: git tag --points-at HEAD [ +1 ms] [ ] 1.22.0-12.4.pre [ +1 ms] 1.22.1 [ ] [ +19 ms] executing: [C:\src\flutter/] git rev-parse --abbrev-ref --symbolic @{u} [ +1 ms] [ +64 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u} [ +1 ms] [ ] origin/stable [ +1 ms] [ ] executing: [C:\src\flutter/] git ls-remote --get-url origin [ +4 ms] [ +55 ms] Exit code 0 from: git ls-remote --get-url origin [ +1 ms] [ ] https://github.com/flutter/flutter.git [ +36 ms] [ +175 ms] executing: [C:\src\flutter/] git rev-parse --abbrev-ref HEAD [ +105 ms] [ +102 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD [ +1 ms] [ ] stable [ +96 ms] [ +139 ms] Artifact Instance of 'AndroidMavenArtifacts' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update. [ ] [ +11 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update. [ +90 ms] [ +9 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update. [ +1 ms] [ +1 ms] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update. [ ] [ +1 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update. [ +1 ms] [ +45 ms] Artifact Instance of 'MaterialFonts' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'GradleWrapper' is not required, skipping update. [ ] [ ] Artifact Instance of 'AndroidMavenArtifacts' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update. [ ] [ ] Artifact Instance of 'FlutterSdk' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update. [ ] [ +11 ms] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update. [ +1 ms] [ +2 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update. [ ] [ +1 ms] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update. [ ] [ +1 ms] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update. [ ] [ +1 ms] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update. [ +1 ms] [ ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update. [ ] [ ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update. [ +172 ms] [ +205 ms] Initializing file store [ +100 ms] [ +74 ms] Done initializing file store [ +300 ms] [ +310 ms] Skipping target: gen_localizations [+16002 ms] [+15942 ms] kernel_snapshot: Starting due to {InvalidatedReason.inputChanged} [ +1 ms] [ +66 ms] C:\src\flutter\bin\cache\dart-sdk\bin\dart.exe --disable-dart-dev C:\src\flutter\bin\cache\artifacts\engine\windows-x64\frontend_server.dart.snapshot --sdk-root C:\src\flutter\bin\cache\artifacts\engine\common\flutter_patched_sdk/ --target=flutter -Ddart.developer.causal_async_stacks=true -Ddart.vm.profile=false -Ddart.vm.product=false --bytecode-options=source-positions,local-var-info,debugger-stops,instance-field-initializers,keep-unreachable-code,avoid-closure-call-instructions --enable-asserts --track-widget-creation --no-link-platform --packages P:\flutter\book_club.packages --output-dill P:\flutter\book_club.dart_tool\flutter_build\6af7d602fe72f9c96aee324a0684b48b\app.dill --depfile P:\flutter\book_club.dart_tool\flutter_build\6af7d602fe72f9c96aee324a0684b48b\kernel_snapshot.d package:book_club/main.dart

dependencies

dependencies: provider: ^4.3.2+3 hexcolor: ^1.0.6 firebase_auth: ^0.18.3+1 firebase_core: ^0.5.2+1 google_sign_in: ^4.5.6 cloud_firestore: ^0.14.4 flutter: sdk: flutter

That's a useful answer
Without any help

@BrightCode1 this seems a problem with FlutterFire rather than flutter I recommend to open an issue in the dedicated github

Ok