Useful or not, from you.
gulp Gulp 3 is broken on Node 12

What were you expecting to happen?

Gulp does anything useful

What actually happened?

Gulp throws the following error:

fs.js:27
const { Math, Object, Reflect } = primordials;
                                  ^

ReferenceError: primordials is not defined
    at fs.js:27:35
    at req_ (/tmp/node_modules/natives/index.js:143:24)
    at Object.req [as require] (/tmp/node_modules/natives/index.js:55:10)
    at Object.<anonymous> (/tmp/node_modules/gulp/node_modules/graceful-fs/fs.js:1:37)
    at Module._compile (internal/modules/cjs/loader.js:759:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:770:10)
    at Module.load (internal/modules/cjs/loader.js:628:32)
    at Function.Module._load (internal/modules/cjs/loader.js:555:12)
    at Module.require (internal/modules/cjs/loader.js:666:19)
    at require (internal/modules/cjs/helpers.js:16:16)

If using a TypeScript gulpfile with ts-node and typescript, the error looks like the following instead:

/tmp/node_modules/natives/index.js:143
    fn(internalBinding)(nm.exports, cachingRequire, nm, nm.filename, '<no dirname available>')
                       ^
ReferenceError: primordials is not defined
    at fs.js:27:35
    at req_ (/tmp/node_modules/natives/index.js:143:24)
    at Object.req [as require] (/tmp/node_modules/natives/index.js:55:10)
    at Object.<anonymous> (/tmp/node_modules/gulp/node_modules/graceful-fs/fs.js:1:37)
    at Module._compile (internal/modules/cjs/loader.js:759:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:770:10)
    at Module.load (internal/modules/cjs/loader.js:628:32)
    at Function.Module._load (internal/modules/cjs/loader.js:555:12)
    at Module.require (internal/modules/cjs/loader.js:666:19)
    at require (internal/modules/cjs/helpers.js:16:16)

Please post a sample of your gulpfile (preferably reduced to just the bit that's not working)

This reproduces with an empty gulpfile

What version of gulp are you using?

3.9.1

What versions of npm and node are you using?

npm: 6.9.0 node: 12.0.0

That's a useful answer
Without any help

I will reiterate what @phated said. Gulp 3 is no longer supported.

@JRetza if you are able to reproduce that error on gulp version 4+ you can open a new issue.