Useful or not, from you.
gulp gulp can't find gulp-notice in ZSH

This tracker is for bug reports only.

Before opening an issue, please make sure you've checked the following:

  • For support requests, please use Stack Overflow (stackoverflow.com) or Gitter (see the README).

  • If the bug is in a plugin, open an issue on the plugin repository, not the gulp repository.

  • If you're getting a deprecated module warning, don't worry about it: we're aware of it and it's not an issue. To make it go away, update to Gulp 4.0.

  • If you're asking about the status of Gulp 4, please don't! You can see the remaining issues on the gulp4 label: https://github.com/gulpjs/gulp/issues?q=is%3Aissue+is%3Aopen+label%3Agulp4


What were you expecting to happen? Gulp to run under ZSH

What actually happened? gulp fails with "zsh: command not found: gulp-notice". this would indicate a problem with ZSH, it's not, it's GULP

Please post a sample of your gulpfile (preferably reduced to just the bit that's not working) It's not the gulpfile, it's gulp itself, I don't use gulp-notice

gulp.task(function () {});

What version of gulp are you using? gulp 4.0.0

What versions of npm and node are you using? npm: 6.9.0 // node: 10.16.0

That's a useful answer
Without any help

Issues are reserved for bugs and features. Here are a few places to find answers to your question:

  • For community support, use the gulp tag on StackOverflow.
  • Participate in community chat on Gitter.
  • To get paid support directly from the maintainers, sign up for Tidelift. Subscribers should email support@tidelift.com, mention that it's a question for Gulp, and describe your question. Straightforward questions are answered as part of your subscription. Additional consulting hours are available for more complex help.