Useful or not, from you.
vscode Failed to save ...: The content of the file is newer. Please compare your version with the file contents.
  • VSCode Version: 1.36.1
  • OS Version: openSUSE Leap 15.0

Steps to Reproduce:

  1. Change git branch
  2. Change file, try to save in new branch
  3. One out of 20 times get the error :)

It is extremely frustrating seeing this from time to time! I have to open another editor/IDE in order to make my changes.

That's a useful answer
Without any help

Only happens with dirty files. Doesn't matter where the file is in the stack.