Useful or not, from you.
node-gyp Is this an Issue with MACOS catalina?

EDITED FOR PEOPLE JUST GETTING HERE:

node-gyp v7 should solve these issues.

Please follow the steps in macOS_Catalina.md

sha3@1.2.3 install /Users/drjosephdavids/node_modules/keccakjs/node_modules/sha3 node-gyp rebuild

No receipt for 'com.apple.pkg.CLTools_Executables' found at '/'.

No receipt for 'com.apple.pkg.DeveloperToolsCLILeo' found at '/'.

No receipt for 'com.apple.pkg.DeveloperToolsCLI' found at '/'.

gyp: No Xcode or CLT version detected! I'M RUNNING XCODE 11.2beta gyp ERR! configure error gyp ERR! stack Error: gyp failed with exit code: 1 gyp ERR! stack at ChildProcess.onCpExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16) gyp ERR! stack at ChildProcess.emit (events.js:198:13) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12) gyp ERR! System Darwin 19.0.0 gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd /Users/drjosephdavids/node_modules/keccakjs/node_modules/sha3 gyp ERR! node -v v10.16.3 gyp ERR! node-gyp -v v5.0.5 gyp ERR! not ok npm WARN enoent ENOENT: no such file or directory, open '/Users/drjosephdavids/package.json' npm WARN drjosephdavids No description npm WARN drjosephdavids No repository field. npm WARN drjosephdavids No README data npm WARN drjosephdavids No license field.

npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! sha3@1.2.3 install: node-gyp rebuild npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the sha3@1.2.3 install script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in: npm ERR! /Users/drjosephdavids/.npm/_logs/2019-10-16T17_41_20_021Z-debug.log

<!-- Thank you for reporting an issue. The more information you can give us, the better the chance we can fix your problem.

This issue tracker is for issues with node-gyp, if you have an issue installing a specific module, please file an issue on that module's issue tracker (npm issues modulename). -->

  • Node Version: <!-- node -v and npm -v -->
  • Platform: <!-- uname -a (UNIX), or systeminfo | findstr /B /C:"OS Name" /C:"OS Version" /C:"System Type" (Windows) -->
  • Compiler: <!-- cc -v (UNIX) or msbuild /version & cl (Windows) -->
  • Module: <!-- what you tried to build/install -->

<details><summary>Verbose output (from npm or node-gyp):</summary>

Paste your log here, between the backticks. It can be:
  - npm --verbose output,
  - or contents of npm-debug.log,
  - or output of node-gyp rebuild --verbose.

</details>

<!-- Any further details -->

That's a useful answer
Without any help

When I run gcc -v I get this

Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/4.2.1
Apple clang version 11.0.0 (clang-1100.0.32.5)
Target: x86_64-apple-darwin19.0.0
Thread model: posix
InstalledDir: /Library/Developer/CommandLineTools/usr/bin