Useful or not, from you.
platformio-vscode-ide Erreurs #include détectées. Mettez à jour includePath. Les tildes sont désactivés pour cette unité de traduction

the issue come from the line : "#include <Arduino.h>"

That's a useful answer
Without any help

Ok, your temporary solution works. I had to uninstall the PlatformIO though, then uninstall the C/C++ Intellisense extension, then reinstall it, decline the upgrade to "0.26.2-insiders2" and reinstall PlatformIO.

It looks like the extension doesn't downgrade if PlatformIO is installed..